aufbereiten Betrags- und Mengenfelder

SFP..SAPscript (Transaktion SE71)..Smartforms (TA Smartforms).. Interactive Forms..Transaktion EFRM)..SIFBA..IAF..AIF..SIFBA - SAP_Interactive_Forms_based_on_Adobe // LÖSUNGSANSÄTZE aber AUCH FÜR "NORMALE" PDFs VERWENDBAR ;-)
Antworten
Guenni_OW
Beiträge: 7
Registriert: 04.12.2013, 00:09

aufbereiten Betrags- und Mengenfelder

Beitrag von Guenni_OW » 09.03.2017, 09:03

Hallo zusammen,

ich habe ein Problem im Angebots- / Auftragsbestätigungsformular bei der Darstellung von Betrags- und Mengenfeldern. Als Ursprung verwende ich das SAP-Standardformular SD_SDOC_FORM01 (Druckprogramm: SD_SDOC_PRINT01). Bei ausländischen Kunden mit Kommunikationssprache DE werden diese Felder "englisch" aufbereitet, d.h. das Dezimalkomma wird als Punkt und der Tausendertrennpunkt als Komma dargestellt. Die Datumsaufbereitung dagegen ist wie erwartet in deutscher Darstellung(tt.mm.jjjj).

Bei Sprache DE möchte ich aber die Betrags- und Mengenfelder in "deutscher" Notation (Dezimalkomma als Komma, Tausendertrennpunkt als Punkt).

Da ich dieses Problem auch im Bestell-Formular festgestellt habe (SAP-Standard MEDRUCK_PO) befürchte ich, das ist ein allgemeines SAP-Proglem. Oder hat jemand eine Lösung dafür?

im Voraus schon mal besten Dank für Eure Tipps
Günter Harter

MatthiasSZ
Beiträge: 2
Registriert: 12.03.2018, 10:37

Re: aufbereiten Betrags- und Mengenfelder

Beitrag von MatthiasSZ » 03.05.2018, 09:57

Hallo Herr Harter,

da ich bezüglich des von Ihnen beschriebenen Problems auch schon einige Zeit recherchiere, kenne ich die Lösung (SAP Hinweis 1009564) welche Ihnen bereits im Forum DSAGNet bekannt gemacht wurde:
[...]
Solution to create a custom locale:
1. Start stand-alone LiveCycle Designer.
2. Create a new form by clicking the New button on the toolbar.
3. Add a field to the form, such as a text field, by selecting Insert Standard [object].
4. Set the locale for the field to a locale that approximates the locale you want to define:
- In the Object palette, click the Field tab.
- In the Locale list, select the locale you want.
5. Select View XML Source.
6. Locate the LocaleSet definition in the form's XML source, and copy it to the clipboard.
7. In a text editor, create a new file and paste the LocaleSet definition into the file. Note that the <LocaleSet> tag must be enclosed in following <xdp> tag:

<xdp:xdp xmlns:xdp="http://ns.adobe.com/xdp/">
<localeSet>...</localeSet>
</xdp:xdp>

8. Make the necessary adjustments to the definition. For the values for setting locale characteristics, see the chapter "Locale Set Specification" in the XML Forms Architecture (XFA) Specification
9. Navigate to the /<DIR_GLOBAL>/AdobeDocumentServices/lib directory.
10. Save the file in XML format. For example, save the file as custom_locale.xml.
11. Modify the custom_xfa.xci file to point to the new custom locale file. If custom_xfa.xci does not exist, copy the xfa.xci file in this directory to custom_xfa.xci. Use the example below as a guideline for changing your file:

<xfa>
<config>
<present>
<common>
<localeSet>\<DIR_GLOBAL>\AdobeDocumentServices\lib\custom_locale.xml</localeSet>
</common>
</present>
</config>
</xfa>

Remark: Space or CR code must not be added within <localeSet> tag.

1. Save custom_xfa.xci.
[...]

Leider habe ich bisher noch keine erfolgreiche Umsetzung geschafft.
Im Anhang befindet sich die von mir erstellte Gebietsschema Datei.

Viele Grüße und schon mal Danke im Voraus für Hilfe und Tipps,
Matthias Schildbach
custom_locale.xml
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen. Bitte logge dich ein oder registriere einen Account.

MatthiasSZ
Beiträge: 2
Registriert: 12.03.2018, 10:37

Re: aufbereiten Betrags- und Mengenfelder

Beitrag von MatthiasSZ » 17.05.2018, 15:32

Nun funktioniert es.
Das (Default-)Standardgebietsschema en_US muss in der custom_locale.xml zwingend definiert werden.
Zusätzlich zu den eigen-definierten Gebietsschemata, müssen auch die ISO Standard Gebietsschemata welche weiterhin greifen sollen, definiert werden.

Schöne Grüße,
Matthias Schildbach

Antworten